Maintained by: NLnet Labs

MacOS Sierra vs. unbound?

Jaap Akkerhuis
Tue Dec 13 09:55:54 CET 2016

 "W.C.A. Wijngaards via Unbound-users" writes:

 > Viktor,
 > On 10/12/16 21:41, Viktor Dukhovni via Unbound-users wrote:
 > > I waited until this week before upgrading from El Capitan to Sierra,
 > > but perhaps that was not quite long enough...  After the upgrade
 > > "unbound" has become unusable, it stops responding under load.
 > > Has anyone been able to build a working unbound for MacOS Sierra?
 > It seems to work fine on MacOS for me (but I may not have tried Sierra,
 > I tried uname version 16).

I'm running it (the version with comes with dnssec-trigger, i think it is rather old) on my
laptop for months. No problem.

 > Is this that macos that inhibits file changes in places and that breaks
 > your setup, or is the firewall inhibiting network access?  It should
 > work, but if it doesn't maybe enable verbosity higher and see why the
 > queries time out; i.e. what unbound is saying (and I guess that the
 > local firewall is inhibiting network access?).

If you want, I'm happy to try to out you test case (send it to me
off-list) on a sierra machine with the latest version of ubound.