Maintained by: NLnet Labs

MacOS Sierra vs. unbound?

W.C.A. Wijngaards
Tue Dec 13 09:45:22 CET 2016


On 10/12/16 21:41, Viktor Dukhovni via Unbound-users wrote:
> I waited until this week before upgrading from El Capitan to Sierra,
> but perhaps that was not quite long enough...  After the upgrade
> "unbound" has become unusable, it stops responding under load.
> Has anyone been able to build a working unbound for MacOS Sierra?

It seems to work fine on MacOS for me (but I may not have tried Sierra,
I tried uname version 16).

Is this that macos that inhibits file changes in places and that breaks
your setup, or is the firewall inhibiting network access?  It should
work, but if it doesn't maybe enable verbosity higher and see why the
queries time out; i.e. what unbound is saying (and I guess that the
local firewall is inhibiting network access?).

Best regards, Wouter

> I tried using the latest libevent from github with the the latest
> unbound with no luck.  For now, I've switched to using BIND 9.11.2.
> The load in question has unbound doing DNSSEC-validation for parallel
> queries (50 to 100 client threads making queries against a loopback
> resolver) that search for MX records, and associated A/AAAA/TLSA
> records.
> Prior to the Sierra upgrade this would run at around 50 domains
> per second.  After the upgrade, all the lookups time out.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <>