Maintained by: NLnet Labs

[Unbound-users] [1.5.0] Compile error on Debian Lenny

Jeroen Massar
Sat Nov 29 21:35:58 CET 2014

On 2014-11-29 21:19, Saturas wrote:
> Hello,
> i´m trying to compile Unbound 1.5.0 for my old Debian Lenny box.
> 1.4.22 runs fine so far. OpenSSL is self-compiled - "OpenSSL 1.0.1j 15
> Oct 2014". Kernel is stock - "Linux debian 2.6.26-2-686 #1 SMP Sun Mar
> 4 22:19:19 UTC 2012 i686 GNU/Linux" and GCC is 4.3.2.
> $ export CFLAGS="-march=pentium3 -msse -O2"
> $ ./configure --prefix=/opt/unbound --with-ssl=/opt/ssl --with-pthreads

Debian does not store SSL in /opt/ hence why are you pointing there?

Also, why not simply backport the Debian package? That is, get the new
package from the repo (add source repo, apt-get source unbound,
dpkg-buildpackage -b...) ?

> $ make
> [...]
> ./libtool --tag=CC --mode=compile gcc -I.  -I/opt/ssl/include
> -march=pentium3 -msse -O2 -pthread -o getentropy_linux.lo -c
> compat/getentropy_linux.c
> libtool: compile:  gcc -I. -I/opt/ssl/include -march=pentium3 -msse
> -O2 -pthread -c compat/getentropy_linux.c  -fPIC -DPIC -o
> .libs/getentropy_linux.o
> In file included from compat/getentropy_linux.c:51:
> /usr/include/linux/random.h:38: error: expected
> specifier-qualifier-list before '__u32'

Seems you are missing a define somewhere. Likely a:
 #define __u32 uint32_t

would likely save the day. Though that is something that should be
defined by the configure. Most very likely you simply do not have the
ssl libs there.