Maintained by: NLnet Labs

[Unbound-users] Parent child disagreement problem

W.C.A. Wijngaards
Wed May 19 15:29:35 CEST 2010

Hash: SHA1

Hi Dustin, Paul, Mike,

Fixed the lookups (in svn trunk), but I cannot see what
is going wrong for  Dustin, do you have a tcpdump
or perhaps a high verbosity trace from unbound (or unbound-host) with
the error?

Best regards,

On 05/13/2010 04:37 PM, Dustin Marquess wrote:
> Not sure if it's similar, but the wife was trying to go to one of those
> designer check places that always sends you junk in the mail... in this
> case <>.
> Lookups always SERVFAIL for the domain
> <>.  Running unbound in debug, it always sets
> the results to THROWAWAY.  I tried to debug it, but it quickly went over
> my head.
> Went back to my old dnscache setup that unbound replaced, and it worked
> fine :(.
> -Dustin
> On Thu, May 13, 2010 at 8:26 AM, Paul Wouters <paul at
> <mailto:paul at>> wrote:
>     On Thu, 13 May 2010, Mike Emigh wrote:
>         We ran across a new problem in what appears to be parent-child
>         disagreement on version 1.4.4.  The resolution appears to work as
>         expected when digging for A records in the domain, but if you first
>         dig for the NS (starting with an empty cache), then subsequent A
>         record lookups fail.
>         If you dig <> NS, it returns
>         an invalid response:
>         ;; ANSWER SECTION:
> <>.         3600    IN    
>          NS      netdns.
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -