Maintained by: NLnet Labs

[Unbound-users] Old entries in the requestlist

Brian Widdas
Wed Jun 30 18:21:41 CEST 2010


I'm running unbound-1.4.3 on a pair of busy Linux caches. It has been
compiled with libevent.

The request list is slowly filling up. I've tried various sizes (it's
currently 4 threads with 4096 requests/thread, so 16384 in total), and
the request list always fills up (and starts discarding incoming
queries). unbound-control dump_requestlist shows entries that are
hours old, eg

175    A IN 2047.857478
iterator wants AAAA IN AAAA IN
 311    A IN 2104.565184 iterator wants AAAA IN AAAA IN

294    A IN 12574.009854 iterator wait for (empty_list)
316    A IN 12811.485119 iterator wait for

Has anyone else seen this? Why aren't they being discarded when they
reach a certain age?

I've not tried a more recent version of Unbound, but I didn't see
anything in the release notes to suggest this issue is fixed. I was
running 1.4.3 on Solaris 10 before without noting this problem.