Maintained by: NLnet Labs

[Unbound-users] Unbound fails to stub-zone to localhost

W.C.A. Wijngaards
Wed Oct 1 15:28:39 CEST 2008

Hash: SHA1

Hi Martin,

What is the NS RRset of ?
dig @ NS
Unbound will send to the servers named in the NS set in preference to
the configured   From the below, it could be that the NS set
is either empty or for example.

This may help you. In svn trunk I recently fixed unbound so that you can
run with stub-addr: at 10053  with NSD running on port 10053 on
localhost.   When you use the '@' for port notation (in the svn trunk
version) the NS record set is not used in preference.

option (d) should have worked, I think.  Maybe there is something else
amiss.  If this doesn't work, tell me what unbound says when verbosity:
4 is set.

Best regards,

martin f krafft wrote:
> Hi,
> I am trying to get unbound, bound to eth0, to forward queries for
> local zones to nsd running on
> nsd works authoritatively, I have verified this with dig.
> Also, when I use pdns-recursor to forward to nsd, it all works.
> However, with unbound, I get SERVFAIL from unbound, which reports:
>   unbound: [1269:0] info: processQueryTargets: < NS IN>
>   unbound: [1269:0] debug: out of query targets -- returning SERVFAIL
> in the logs. My configuration is as follows. What could be the
> problem?
>   server:
>     verbosity: 1
>     interface:
>     cache-max-ttl: 1800
>     access-control: refuse
>     access-control: allow
>     access-control: allow
>     chroot: ""
>     do-not-query-localhost: no
>   stub-zone:
>     name: ""
>     stub-addr:
> I have tried
> (a) forward-zone for and .
> (b) stub-zone for and forward-zone for .
> (c) only stub-zone for and root-hints for .
> (d) only forward-zone for and root-hints for .
> (e)/(f) like (c)/(d) without explicit root-hints
> but in none of these cases could I make it work.
> Any clues?
> ------------------------------------------------------------------------
> _______________________________________________
> Unbound-users mailing list
> Unbound-users at

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -