[nsd-users] can't compile current svn

W.C.A. Wijngaards wouter at NLnetLabs.nl
Mon Mar 7 09:21:25 CET 2011


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Chris,

On 03/07/2011 04:24 AM, Chris Smith wrote:
> Hello,
> 
> Having some issues with the current svn version 3206.

Current svn is NSD4 in development and contains work in progress.
However it should compile ...

If you desire the RC it is in tags/NSD_3_2_8_RC1

> Note that it could be my systems as previously built versions no
> longer compile either with gcc-4.5.2 and glibc-2.13.

Thanks for the errorlog.  I know this bug from the ubuntu system
headers.  If does not happen on other linuxes I believe.  I think I
already saw a bugreport for it.  I do not expect it to get fixed, maybe
in later ubuntu releases, I guess a configure compile test is needed to
stop using advanced optimization.

> However, just in case... these are the errors:
> =======================================
> nsd.c:867:3: warning: ignoring return value of ‘chown’, declared with
> attribute warn_unused_result
> radtree.c: In function ‘radix_delete’:
> /usr/include/bits/string3.h:49:1: sorry, unimplemented: inlining
> failed in call to ‘memcpy’: redefined extern inline functions are not
> considered for inlining
> radtree.c:622:8: sorry, unimplemented: called from here
> /usr/include/bits/string3.h:56:1: sorry, unimplemented: inlining
> failed in call to ‘memmove’: redefined extern inline functions are not
> considered for inlining
> radtree.c:626:9: sorry, unimplemented: called from here
> /usr/include/bits/string3.h:56:1: sorry, unimplemented: inlining
> failed in call to ‘memmove’: redefined extern inline functions are not
> considered for inlining
> radtree.c:671:9: sorry, unimplemented: called from here
> make: *** [whole] Error 1
> =======================================
> 
> The current code does build fine with gcc-4.4.3 and glibc-2.11.1 and
> will build with gcc-4.5.2 and glibc-2.13 if I enforce the CFLAG
> -fno-inline although I'm guessing that should not be necessary.
> 
> Any assistance is appreciated.
> 
> Thank you,

Best regards,
   Wouter
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org/

iEYEARECAAYFAk10lYUACgkQkDLqNwOhpPiowACgtk4xs3rwxtES6gMTl8QMdHw9
Iq8AmgIQbhCzd072CT9iFk4sTvYlnOup
=6jnn
-----END PGP SIGNATURE-----


More information about the nsd-users mailing list