Bug 1267 - Libunbound validator/val_secalgo.c uses obsolete APIs
Libunbound validator/val_secalgo.c uses obsolete APIs
Status: RESOLVED FIXED
Product: unbound
Classification: Unclassified
Component: server
unspecified
Other Linux
: P5 normal
Assigned To: unbound team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-18 00:00 CEST by hyc
Modified: 2017-05-18 09:18 CEST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hyc 2017-05-18 00:00:13 CEST
EVP_VerifyInit and EVP_VerifyUpdate were #defined to EVP_DigestInit and EVP_DigestUpdate in OpenSSL back in 2001. Using the obsolete names causes build issues with "OpenSSL-compatible" libraries like boringssl (which is used in recent Android releases).

Please change to the new function names.
Comment 1 Wouter Wijngaards 2017-05-18 09:18:11 CEST
Hi Hyc,

Thank you for the report.  I didn't know it was obsolete (openssl has many #defines).  The header file, and also man pages do not say it is obsolete at all.  In fact, I think it is not obsolete?

But I'll adjust the fix for compatibility with BoringSSL.  It seems to be fine for OpenSSL and LibreSSL too.

Best regards, Wouter