Bug 1258 - Windows 10 X64 unbound 1.6.2 service will not start; also it installs in C:\Program Files (x86)
Windows 10 X64 unbound 1.6.2 service will not start; also it installs in C:\P...
Status: RESOLVED FIXED
Product: unbound
Classification: Unclassified
Component: server
1.6.2
x86_64 Windows
: P5 critical
Assigned To: unbound team
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-04-27 20:21 CEST by jurek0001
Modified: 2017-06-21 08:44 CEST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jurek0001 2017-04-27 20:21:16 CEST
Hello,
unbound 1.6.2 64-bit version is supposed to install in C:\Program Files, but installs in C:\Program Files (x86). It was reported in bug #1224, ans closed as solved, but obviously is not solved.
But critical is that Unbound DNS validator (path to exec: "C:\Program Files (x86)\Unbound\unbound.exe" -c "C:\Program Files (x86)\Unbound\service.conf" -w service) runs as Local System Account, but the service terminates unexpectedly:
The Unbound DNS validator service terminated unexpectedly.  It has done this 5 time(s).
- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" /> 
  <EventID Qualifiers="49152">7034</EventID> 
  <Version>0</Version> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x8080000000000000</Keywords> 
  <TimeCreated SystemTime="2017-04-27T18:18:10.520269700Z" /> 
  <EventRecordID>268953</EventRecordID> 
  <Correlation /> 
  <Execution ProcessID="700" ThreadID="7040" /> 
  <Channel>System</Channel> 
  <Computer>Jerzy-6400-764</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data Name="param1">Unbound DNS validator</Data> 
  <Data Name="param2">5</Data> 
  <Binary>75006E0062006F0075006E0064000000</Binary> 
  </EventData>
  </Event>
Any suggestions how to overcome this problem?
Sincerely,
Jerzy
Comment 1 jurek0001 2017-04-28 18:27:34 CEST
upon further investigation I find multiple errors loged in Windows applications log, while starting the unbound service:
1. [C:\Program Files (x86)\Unbound\unbound.exe:0] error: unable to open C:\Program Files (x86)\Unbound\root.key for reading: No such file or directory
And truely, there is no such file there.

2. [C:\Program Files (x86)\Unbound\unbound.exe:0] error: error reading auto-trust-anchor-file: C:\Program Files (x86)\Unbound\root.key

3. [C:\Program Files (x86)\Unbound\unbound.exe:0] error: validator: error in trustanchors config

4. [C:\Program Files (x86)\Unbound\unbound.exe:0] error: validator: could not apply configuration settings.
But configuration file is set.

5. [C:\Program Files (x86)\Unbound\unbound.exe:0] error: module init for module validator failed

6. [C:\Program Files (x86)\Unbound\unbound.exe:0] fatal error: failed to setup modules
Please, do not hesitate to contact me, if you need any additional information.
Sincerely,
Jerzy
Comment 2 jurek0001 2017-04-28 20:51:34 CEST
Hi,
more info:
It appears that 64-bit versions of unbound v.1.6.1 and v.1.6.2 do not install root.key file in the unbound directory (the file is missing), and that is why the service fails to start (I did not test 32-bit versions). Once root.key file is copied from v.1.6.0 version, which installs that file, 1.6.2 version service starts successfully.
Sincerely,
Jerzy
Comment 3 Wouter Wijngaards 2017-05-01 16:51:36 CEST
Hi Jurek,

Thank you for the detailed bugreport, I was able to fix the issue.  The unbound .zip and .exe installer include the root.key file now, so that it should exist when you start the unbound service.  And that should fix the failure to start issue.

Best regards, Wouter
Comment 4 Wouter Wijngaards 2017-05-01 16:59:26 CEST
Hi Jurek,

I have also fixed the install location, it turns out I previously fixed other x86 mentions, but in the nsis script it used $PROGRAMFILES instead of $PROGRAMFILES64 for the 64bit install.

Best regards, Wouter
Comment 5 jurek0001 2017-06-16 17:54:49 CEST
This bug has NOT been fixed and in version 1.6.3 x64 still does NOT install rook.key!!!
Comment 6 Wouter Wijngaards 2017-06-19 09:30:28 CEST
Hi Jurek,

Yes indeed, it is not fixed in 1.6.3.  The fix I made for this is schedules for 1.6.4 (upcoming in this week).  The 1.6.3 has a point-release which was 1.6.2 with a security-related bugfix.  Hence all the scheduled fixes for 1.6.4 did not make it in there.  Because I do not want to 'soil' the security related release with potential wrong other stuff.

(I was looking for a solid ten minutes for what was wrong until I also realised that it simply isn't in 1.6.3; it was scheduled for 1.6.3, but then a 1.6.2 + security bugfix became 1.6.3, and it is now scheduled for 1.6.4).

I am however, grateful for the test and bugreport, since I have not much to go on for the Windows port in general which makes support hard for me.

So the fix is still in the development trunk and release candidate 1 of 1.6.4 is upcoming shortly.

Best regards, Wouter
Comment 7 jurek0001 2017-06-20 22:05:19 CEST
Hello,
It appears this bug and bug #1261 have been mitigated and resolved in unbound v1.6.4rc1.
Namely, here root.key is not missing anymore, and it installed during installation process. And x64 version installs in proper C:\Program Files\Unbound\ directory
Thank you.
Should I close these tickets, or will you do it?
Sincerely,
Jerzy
Comment 8 Wouter Wijngaards 2017-06-21 08:44:34 CEST
Hi Jurek,

Good that it works!

Best regards, Wouter